Upload Assets doesn't work

Information and discussions on the Broadleaf Commerce Admin Tool

Moderator: jocanas

SantoDE
Newbie
Newbie
Posts: 11
Joined: Wed Jul 13, 2016 3:04 pm

Upload Assets doesn't work

Postby SantoDE » Wed Jul 13, 2016 3:10 pm

Heya,

I got another weird problem on my demosite.

I can't add any static media. If I click on the Upload Assets button just nothing happens. I've also created a github issue.

https://github.com/BroadleafCommerce/De ... issues/187

Hope you guys have an idea!

Cheers,
SantoDE

jocanas
Newbie
Newbie
Posts: 14
Joined: Mon Jan 23, 2012 4:40 pm

Re: Upload Assets doesn't work

Postby jocanas » Wed Jul 13, 2016 3:42 pm

Hi Manuel,

Thank you for pointing this issue out. We just ran a test against the community edition and were able to see the issue that you mentioned. We'll be opening up an issue and prioritizing it for a future release.

Thanks,
Jerry

SantoDE
Newbie
Newbie
Posts: 11
Joined: Wed Jul 13, 2016 3:04 pm

Re: Upload Assets doesn't work

Postby SantoDE » Wed Jul 13, 2016 4:19 pm

Hi Jerry,

once again, thanks for your fast replie! Glad to see that you guys take care of it.

As this one is not working currently, I've a follow up question :

Is it possible to somehow reuse the static asset functionality to introduce a special typ of files (e.g. XML files) and reuse the upload functionality within my own custom admin module? That's the reason why I wanted to test out the upload functionality :-)

Thanks!

Regards,
Manuel

jocanas
Newbie
Newbie
Posts: 14
Joined: Mon Jan 23, 2012 4:40 pm

Re: Upload Assets doesn't work

Postby jocanas » Thu Jul 14, 2016 9:04 am

Hi Manuel,

For what you want you may want/need to clean up the UI if your building out a custom section, but as far as uploading xml assets, yes, it is supported.

You should even be able to test this out if you go to http://www.broadleafcommerce.com/ and sign up for a free demo. Grant it, the demo you see is loaded with all the enterprise goodies but you can test out the functionality of uploading files.

Here's a sample of a random one I created in a demo site I signed up for: http://demo25cg1w.broadleafcommerce.org ... c/note.xml

Note that out of box, all files uploaded are prepended with:

Code: Select all

cmsstatic/


Meaning that if you upload anything, you'll need to add that to your URL (you can see it in the sample link I posted above).

Regards,
Jerry

sumit17mar
Newbie
Newbie
Posts: 5
Joined: Tue Dec 27, 2016 8:34 am

Re: Upload Assets doesn't work

Postby sumit17mar » Wed Jan 04, 2017 6:20 am

Hi All,

Please let me know if this issue is resolved .
I cannot add new asset image for a new product.

Even when I try from products --> select asset -->upload new asset , it does not work .

It throws error :
SEVERE: Servlet.service() for servlet [admin] in context with path [/admin] threw exception
java.lang.RuntimeException: org.springframework.web.util.NestedServletException: Request processing failed; nested exception is java.lang.NullPointerException
at org.broadleafcommerce.openadmin.web.filter.BroadleafAdminRequestFilter$1.execute(BroadleafAdminRequestFilter.java:85)

Caused by: java.lang.NullPointerException
at org.broadleafcommerce.openadmin.audit.AdminAuditableListener.setAuditCreatedBy(AdminAuditableListener.java:38)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

[ERROR] 16:49:50 AdminBasicOperationsController - [JS] - (http://localhost:8081/admin/js/admin/ve ... 1.min.js:4) - SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

jocanas
Newbie
Newbie
Posts: 14
Joined: Mon Jan 23, 2012 4:40 pm

Re: Upload Assets doesn't work

Postby jocanas » Wed Jan 04, 2017 9:29 am

Yes, this issue should have been resolved in the 5.0.3-GA release (note, we just released 5.0.6-GA).

sumit17mar
Newbie
Newbie
Posts: 5
Joined: Tue Dec 27, 2016 8:34 am

Re: Upload Assets doesn't work

Postby sumit17mar » Mon Jan 09, 2017 6:40 am

The issue exists in 5.0.0.3 and 5.0.0.5 as well :(


Return to “Broadleaf Commerce Admin”

Who is online

Users browsing this forum: No registered users and 1 guest