3.0 Migration With OMS and PriceList

Forum for questions and issues related to 3.0 migration.

Those wishing to upgrade should start by looking at the migration documents published on the Broadleaf Commerce documentation site.

Moderator: jocanas

magicbacon
Newbie
Newbie
Posts: 1
Joined: Wed Dec 26, 2012 11:39 am

3.0 Migration With OMS and PriceList

Postby magicbacon » Mon Jul 27, 2015 1:02 pm

Hi,

I'm currently working on migrating 2.3 to 3.0. We are using OMS and Price List module in our project.

And when deploying the war, I'm getting a warning and an error.

[ WARN] 13:44:51[adminId:,custId:,programCode:] XmlBeanDefinitionReader - Ignored XML validation warning
org.xml.sax.SAXParseException: SchemaLocation: schemaLocation value = 'http://www.springframework.org/schema/beans http://www.springframework.org/schema/b ... ns-3.2.xsd http://www.springframework.org/schema/tx http://www.springframework.org/schema/t ... tx-3.2.xsd http://www.springframework.org/schema/aop http://www.springframework.org/schema/a ... op-3.2.xsd http://www.springframework.org/schema/util http://www.springframework.org/schema/u ... il-3.2.xsd http://www.springframework.org/schema/context http://www.springframework.org/schema/c ... xt-3.2.xsd http://www.springframework.org/schema/task http://www.springframework.org/schema/t ... sk-3.2.xsd http://schema.broadleafcommerce.org/mo http://schema.broadleafcommerce.org/mo/mo-3.0.xsd http://www.springframework.org/schema/b ... ns-3.1.xsd http://www.springframework.org/schema/t ... tx-3.1.xsd http://www.springframework.org/schema/a ... op-3.1.xsd http://www.springframework.org/schema/c ... xt-3.1.xsd http://schema.broadleafcommerce.org/mo/mo-2.2.xsd http://www.springframework.org/schema/jee http://www.springframework.org/schema/j ... ee-3.2.xsd http://www.springframework.org/schema/cache http://www.springframework.org/schema/c ... he-3.2.xsd http://www.springframework.org/schema/security http://www.springframework.org/schema/s ... ty-3.2.xsd http://www.springframework.org/schema/mvc http://www.springframework.org/schema/m ... c-3.2.xsd' must have even number of URI's.

[ERROR] 13:44:51[adminId:,custId:,programCode:] ContextLoader - Context initialization failed
org.springframework.beans.factory.xml.XmlBeanDefinitionStoreException: Line 2001 in XML document from resource loaded from byte array is invalid; nested exception is org.xml.sax.SAXParseException: cvc-complex-type.2.4.c: The matching wildcard is strict, but no declaration can be found for element 'jee:jndi-lookup'.

Please notice that there are XSD files with different versions. I'm thinking that of OMS module who has lower version of Spring framework dependency might be causing problem.

Do we have instruction or guidelines on how to migrate with OMS and Price List Module?

Thanks.

Return to “3.0 Upgrade and Migration”

Who is online

Users browsing this forum: No registered users and 1 guest